(已解决)ubuntukylin安装google-chrome-stable依赖问题

electing previously unselected package google-chrome-stable.
(正在读取数据库 … 系统当前共安装有 162072 个文件和目录。)
正在解压缩 google-chrome-stable (从 google-chrome-stable_current_amd64.deb) …
dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable 依赖于 libgconf2-4 (>= 2.27.0);然而:
未安装软件包 libgconf2-4。
google-chrome-stable 依赖于 libnss3-1d (>= 3.12.3);然而:
未安装软件包 libnss3-1d。
google-chrome-stable 依赖于 libudev0 (>= 147);然而:
未安装软件包 libudev0。
google-chrome-stable 依赖于 libxss1;然而:
未安装软件包 libxss1。

dpkg: error processing google-chrome-stable (–install):
依赖关系问题 - 仍未被配置
正在处理用于 man-db 的触发器…
正在处理用于 bamfdaemon 的触发器…
Rebuilding /usr/share/applications/bamf.index…
正在处理用于 desktop-file-utils 的触发器…
正在处理用于 gnome-menus 的触发器…
在处理时有错误发生:
google-chrome-stable
mensylee@mensyli-pc:~/下载$ sudo apt-get install -f
正在读取软件包列表… 完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
正在更正依赖关系… 完成
将会安装下列额外的软件包:
libgconf2-4 libnss3-1d
下列软件包将被【卸载】:
google-chrome-stable
下列【新】软件包将被安装:
libgconf2-4 libnss3-1d
升级了 0 个软件包,新安装了 2 个软件包,要卸载 1 个软件包,有 0 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 14.5 kB 的软件包。
解压缩后将会空出 142 MB 的空间。
您希望继续执行吗?[Y/n]
获取:1 http://mirrors.163.com/ubuntu/ raring/main libgconf2-4 amd64 3.2.6-0ubuntu1 [2,046 B]
获取:2 http://mirrors.163.com/ubuntu/ raring/main libnss3-1d amd64 2:3.14.3-0ubuntu1 [12.5 kB]
下载 14.5 kB,耗时 0秒 (31.7 kB/s)
(正在读取数据库 … 系统当前共安装有 162171 个文件和目录。)
正在卸载 google-chrome-stable …
正在处理用于 bamfdaemon 的触发器…
Rebuilding /usr/share/applications/bamf.index…
正在处理用于 desktop-file-utils 的触发器…
正在处理用于 gnome-menus 的触发器…
正在处理用于 man-db 的触发器…
Selecting previously unselected package libgconf2-4:amd64.
(正在读取数据库 … 系统当前共安装有 162072 个文件和目录。)
正在解压缩 libgconf2-4:amd64 (从 …/libgconf2-4_3.2.6-0ubuntu1_amd64.deb) …
Selecting previously unselected package libnss3-1d:amd64.
正在解压缩 libnss3-1d:amd64 (从 …/libnss3-1d_2%3a3.14.3-0ubuntu1_amd64.deb) …
正在设置 libgconf2-4:amd64 (3.2.6-0ubuntu1) …
正在设置 libnss3-1d:amd64 (2:3.14.3-0ubuntu1) …

安装
64位:http://launchpadlibrarian.net/132294155/libudev0_175-0ubuntu19_amd64.deb
32位:http://launchpadlibrarian.net/132294322/libudev0_175-0ubuntu19_i386.deb

直接双击用软件中心装?

软件中心哪有google-chrome呀,我自己下载的,然后sudo dpkg -i google-chrome-stable,
然后提示以来xxx,以前都是sudo apt-get install -f直接解决
但是现在不行

哪里下载?爬墙的吗?我在官网那里一直都下不了

必须爬墙,要不然下不了

我是用goagent配合chrome爬的…

我也是,但是不能安装,依赖解决不了

就没有人解决这个问题么?求教啊

@ubuntukylin

先执行下面的命令:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

sudo sh -c ‘echo “deb http://dl.google.com/linux/chrome/deb/ stable main” >> /etc/apt/sources.list.d/google.list’

sudo apt-get update

然后就可以 apt-get install google-chrome-stable, google-chrome-beta 或 google-chrome-unstable 安装,装哪个就看你要稳定与否。

有依赖问题,不能安装,sudo apt-get install -f无法解决

悲剧,没人鸟

软件中心的叫做chromnium

直接在源里装啊 依赖不是自动解决么

我说的是chrome,不是chromium
chrome有依赖问题,sudo apt-get install -f不能解决

源里的是chromium,不是chrome
chromium可以装,但是chrome有依赖问题,解决不了

[

其实我以前是可以装的
昨天重新装了下beta2,,就不能装了,最新ubuntu13.04 daily也有依赖问题
下列软件包有未满足的依赖关系:
google-chrome-stable : 依赖: libudev0 (>= 147) 但无法安装它
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

真心咋解决啊?缺少 libudev0,源里木有

自己去百度搜这个依赖,在ubuntu里面可以下的,选择最新的

好贴,回答的很详细:3_48::3_48: